41


1

Aptanaの自動_Plugins Manager_を通じて現在入手可能な* Subclipse(1.2.4)*のバージョンは、Subversionの最新バージョンでは動作しません。

SubclipseのWebサイトで、Eclipse用の1.4.2があることがわかりました。 そこで、私のアップデートマネージャに 新しいリモートアップデートサイトを追加しました。 インストールしようとすると、* Mylyn 3.0.0 が必要だと言われました。 それで私はMylyn 3.0.0を見つけ、私のアップデートマネージャに 別の新しいリモートアップデートサイトを追加しました。 それから私がそれをインストールしようとしたとき、それは私が org.eclipse.ui 3.3.0 *または同等のものが必要であると私に言った。

Aptanaの設定の詳細を見ると、eclipse 3.2.2に対して構築されているようです。

誰かが3.3.0にビルドされているEclipse Aptanaのバージョンをアップグレードする方法があるかどうか知っていますか? それとも、Subclipseを最新バージョンのSubversionで動作させる方法が他にあるかどうか。

これは必ずしも「プログラミング」の問題ではないことは知っていますが、プログラミングの経験との関連性が高いので問題ないと思います。

4 Answer


16


SubclipseはMylynを必要としませんが、更新サイトにはMylynとSubclipseを統合するプラグインが含まれています。 これはMylynを使う人々を対象としています。 あなたの場合は、更新ダイアログでMylynの選択を解除するだけです。

SubclipseにはSubversion 1.5とそれに対応するバージョンのJavaHLネイティブライブラリも必要です。 私は、人々がJavaHLを理解し、それをどのように取得するかを助けるためにFAQの始めを書きました。 参照してください:http://desktop-eclipse.open.collab.net/wiki/JavaHL


7


私はEclipse EuropaでうまくいったときにEclipse GanymedeのJavaHLに問題がありました。 Aptanaがどのように違うのかはわかりませんが、JavaHLをアップグレードするか、Subclipse構成内のpure-java SVNKit実装に切り替えてみてください。


4


mylynを使用しないのであれば、その依存関係のチェックを外してください。 私はAptanaにはあまり慣れていませんが、Eclipseではインストールされているものを拡張したり、必要のないものはチェックを外したりすることができます。


3


更新URLを使用し、JavaHLアダプター、Subclipseプロジェクト自体、およびSVNKitアダプターBETAをインストールしました。

この後それは私のためにうまく働きました、これはそれがあなたのために働くことを願っているLinuxプラットフォームのためのものです。