0


0

私はしばらくの間jQuery UI v1.6rc2を使っていて、何も重大な変更を加えていないことを確認するために1.6rc6にアップグレードしたいと思いました。 彼らは持っているようです。 rc6に切り替えると、すべてのタブが機能しなくなります。

2つ問題があるようです。 まず、マニュアルでは以下のことを主張しています。

$( '#container')。tabs();

しかし、rc2ではいつもこれをしなければなりませんでした:

$( '#container> ul')。tabs();

そのため、rc6が有効になっていると、これらのメソッドはどれも機能しません。

また、rc6がインストールされていると、Firebugは次のエラーを報告します。

$ .Eventは関数ではありません。 this.namespace '-state-disabled')。attr( "... event [prop] = event.originalEvent [prop];}}

1 Answer


3


jQueryコアバージョン1.3.1にアップグレードする必要があります。UI 1.6rc6は1.3.1でのみ動作します。