0


0

Rails 2.3.8およびactivesupportランタイムエラー

これは、「スクリプト/サーバー」のときに取得するエラーです。

can't activate activesupport (= 3.0.0, runtime) for [], already activated activesupport-2.3.8 for ["rails-2.3.8"]

私はここで何が起こっていると思いますか? 2.3.8の「activesupport」がすでに機能している場合

助けて?

ありがとう

1 Answer


0


rails 3.0.0およびactivesupport 3.0.0をアンインストールする必要があります。

たとえば、rvmでいくつかの異なるgemsetを使用できます。

別の解決策は、特定のRailsバージョンが内部で定義されているbundlerを使用することです。

バンドラーを使用する場合、バンドラーでサーバーを起動する必要があります

bundle exec script/server