3


0

Declarative_authorizationが読み込まれないようですか?

レール2.3.4でbundlerを実行しています。

declarative_authorizationを機能させようとしています(Gemfileに追加しました)。

私が得ているエラーは「未定義のローカル変数またはメソッド「filter_resource_access」」です。

これは、declarative_authorizationが読み込まれていないことを意味していると思いますか? 私はbundlerを使用しているため、 environment.rb`には config.gem`行がありません。 ただし、追加すると、サーバーを起動しようとして「Uninitialized constant Authorization」というエラーがスローされます。

何をすべきかわからない…​ 助けていただければ幸いです。

1 Answer


3


Rails 2.3.4でbundlerを使用できますか? http://railscasts.com/episodes/188-declarative-authorization [優秀なスクリーンキャスト]に従ってTにアクセスしてください。うまくいかない理由はありません。 宣言的除去は、利用可能な最も強力な承認ソリューションです。