1


0

最新のエッジレールを実行するには、本当にbundler 1.0.0.beta.3をインストールする必要がありますか?

エッジレールをバンドルする「バンドルインストール」を行うと、次のエラーが表示されます。

No compatible versions could be found for required dependencies:
    Conflict on: "bundler":
    * bundler (0.9.26) activated by bundler (= 0.9.26, runtime)
    * bundler (>= 1.0.0.beta.3, runtime) required by rails (>= 0, runtime)
    All possible versions of origin requirements conflict.

bundler 1.0.0.beta.3をインストールせずに最新のエッジレールをインストールする方法はありますか?

1 Answer


0


7月1日、エッジRailsのBundler依存関係が0.9.26から1.0.0.beta.2(および過去数週間の各ベータ)に引き上げられました。 私が知る限り、エッジRailsは0.9.26と完全に互換性があるため、http://github.com/rails/rails/blob/master/rails.gemspec [rails.gemspec]を編集して読むことができるはずです。 :

s.add_dependency('bundler', '>= 0.9.26')

まだBundler 0.9.26を実行しているHerokuに展開されているため、エッジレール上の3つのプロジェクトで既にこれを行っています。 問題やテストが壊れていません。