3


1

Eclipse用のgrailsプラグインを機能させることに成功した人はいますか? netbeansでgrailsプラグインはどうですか?

6 Answer


3


NetBeans 6.5 Betaを使用している場合は、Grails機能は有望ですが、まだバグがあります(マイナー)。 良いことは6.5 Groovyにあり、Grailsのサポートは標準です。プラグインをインストールする必要はありません。


2


残念ながら、Grails用のEclipseプラグインはあまり進歩していません。Grailsの開発用に Intel IDEAを使用し始めました。 /idea/features/groovy_grails.html[JetGroovy]プラグインは優れていて、良くなっています!


2


Netbeans 6.5はGrailsに非常に適していて、デバッグを可能にしますが、コード補完はほんのわずかしかありません。


1


まあ、これは簡単な更新です。 Eclipseプラグインは機能し、リファクタリングをサポートしています。 しかし、どういうわけかEclipseプロジェクトのGrailsプラグインを認識させることができません。

それは一緒に来始めています。


0


Eclipse grailsプラグインがインストールされており、宣伝されているすべての機能を提供している限り、私は問題なく動作しています。 問題は、この一連の機能が最小限で、IntelliJよりも数年遅れていることです。 無料のIDEから商用のIDEに切り替えることはまったく不可能であることを私は理解していますが、もしそうなら、それをしてください! NetbeansはEclipseより優れていますが、IntelliJの背後にはまだかなりの距離があります。


0


将来のドキュメンテーションのためだけに:Netbeans 6.8は非常に素晴らしいGrails / Groovyプラグインで利用可能です。 さらに、新しいCode Coverage Pluginを使用することもできます。 本当にいいビルド。

しかし、GrailsがSpring Sourceに属していることを覚えておく必要があります。 Spring SourceはEclipseをベースにした独自のTool Suiteを開発していることで知られています。 たぶん私たちはEclipseのためのより良いgrailsプラグイン実装を見るでしょう。